Delays in asynchronous notifications

Incident Report for Payyo

Postmortem

On 12 August 2025, between 10:02 UTC and 10:25 UTC, the Payyo API experienced widespread request failures caused by a sales launch from a single merchant.
The sudden spike in API requests exceeded the system’s provisioned capacity, leading to timeouts, failed payments, and duplicate charges as customers retried payment. If you were affected by this we’ve likely already been in contact with you.
The merchant aborted the sales event, but the increase in processed payments caused a delay in webhooks processing. By 14:15 UTC, webhooks processing was back to regular operations.
We apologize for any inconvenience caused. If you have any questions please reach out to your account manager directly.

Posted Aug 15, 2025 - 15:33 UTC

Resolved

We have identified the next steps required for a solution and have worked on a fix. This should now be functioning as expected.
Posted Aug 12, 2025 - 14:18 UTC

Update

We are continuing to investigate this issue.
Posted Aug 12, 2025 - 12:51 UTC

Investigating

We are currently experiencing delays with our asynchronous notifications. This is currently being investigated
Posted Aug 12, 2025 - 12:51 UTC
This incident affected: API.