Since 9:35 UTC all systems are operating normally again. We're still investigating the root cause of the incident. We'll share this information once it is available. We apologise for any inconvenience caused.
Posted Aug 10, 2026 - 13:07 UTC
Investigating
Since 09:10 UTC we're observing elevated error rates on our payments API and are actively investigating and monitoring the situation.
Posted Aug 10, 2026 - 09:55 UTC
This incident affected: API and Hosted Payment Page (HPP).